Reactor Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 7
Number of dependencies (NOD): 118
Number of unique artifacts (NOA): 133
Number of version-conflicting artifacts (NOC): 7
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 88 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in modules

commons-codec:commons-codec

[Error]
1.10
  1. be.e_contract.dssp:dssp-client-wss4j2:jar:1.8.0
    \- org.apache.wss4j:wss4j-ws-security-dom:jar:2.2.5:provided
       \- org.apache.wss4j:wss4j-ws-security-common:jar:2.2.5:provided
          +- org.opensaml:opensaml-saml-impl:jar:3.3.1:provided
          |  +- org.opensaml:opensaml-profile-api:jar:3.3.1:provided
          |  |  +- org.opensaml:opensaml-core:jar:3.3.1:provided
          |  |  |  \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)
          |  |  \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)
          |  +- org.opensaml:opensaml-saml-api:jar:3.3.1:provided
          |  |  +- org.opensaml:opensaml-xmlsec-api:jar:3.3.1:provided
          |  |  |  \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)
          |  |  +- org.opensaml:opensaml-soap-api:jar:3.3.1:provided
          |  |  |  \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)
          |  |  \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)
          |  +- org.opensaml:opensaml-security-impl:jar:3.3.1:provided
          |  |  +- org.opensaml:opensaml-security-api:jar:3.3.1:provided
          |  |  |  \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)
          |  |  \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)
          |  +- org.opensaml:opensaml-xmlsec-impl:jar:3.3.1:provided
          |  |  \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)
          |  +- net.shibboleth.utilities:java-support:jar:7.3.0:provided
          |  |  \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)
          |  \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)
          +- org.opensaml:opensaml-xacml-impl:jar:3.3.1:provided
          |  +- org.opensaml:opensaml-xacml-api:jar:3.3.1:provided
          |  |  \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)
          |  \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)
          \- org.opensaml:opensaml-xacml-saml-impl:jar:3.3.1:provided
             +- org.opensaml:opensaml-xacml-saml-api:jar:3.3.1:provided
             |  \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)
             \- (commons-codec:commons-codec:jar:1.10:provided - omitted for conflict with 1.13)

1.13
  1. be.e_contract.dssp:dssp-client-wss4j2:jar:1.8.0
    \- org.apache.wss4j:wss4j-ws-security-dom:jar:2.2.5:provided
       \- org.apache.wss4j:wss4j-ws-security-common:jar:2.2.5:provided
          \- org.apache.santuario:xmlsec:jar:2.1.5:provided
             \- commons-codec:commons-codec:jar:1.13:provided

commons-collections:commons-collections

[Error]
2.0
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.owasp.esapi:esapi:jar:2.1.0:test
       \- commons-beanutils:commons-beanutils-core:jar:1.7.0:test
          \- (commons-collections:commons-collections:jar:2.0:test - omitted for conflict with 3.2)

3.2
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.owasp.esapi:esapi:jar:2.1.0:test
       +- commons-configuration:commons-configuration:jar:1.5:test
       |  \- (commons-collections:commons-collections:jar:3.2:test - omitted for duplicate)
       \- commons-collections:commons-collections:jar:3.2:test

commons-lang:commons-lang

[Error]
2.3
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.owasp.esapi:esapi:jar:2.1.0:test
       \- commons-configuration:commons-configuration:jar:1.5:test
          \- commons-lang:commons-lang:jar:2.3:test

2.6
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.jboss.shrinkwrap.resolver:shrinkwrap-resolver-depchain:pom:2.1.1:test
       \- org.jboss.shrinkwrap.resolver:shrinkwrap-resolver-impl-maven:jar:2.1.1:test
          +- org.apache.maven.wagon:wagon-file:jar:2.6:test
          |  \- (commons-lang:commons-lang:jar:2.6:test - omitted for conflict with 2.3)
          \- org.apache.maven.wagon:wagon-http-lightweight:jar:2.6:test
             \- org.apache.maven.wagon:wagon-http-shared:jar:2.6:test
                \- (commons-lang:commons-lang:jar:2.6:test - omitted for duplicate)

commons-logging:commons-logging

[Error]
1.0
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.owasp.esapi:esapi:jar:2.1.0:test
       \- commons-beanutils:commons-beanutils-core:jar:1.7.0:test
          \- (commons-logging:commons-logging:jar:1.0:test - omitted for conflict with 1.1.1)

1.0.3
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.owasp.esapi:esapi:jar:2.1.0:test
       \- commons-configuration:commons-configuration:jar:1.5:test
          \- commons-digester:commons-digester:jar:1.8:test
             \- commons-beanutils:commons-beanutils:jar:1.7.0:test
                \- (commons-logging:commons-logging:jar:1.0.3:test - omitted for conflict with 1.1.1)

1.0.4
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.owasp.esapi:esapi:jar:2.1.0:test
       \- org.owasp.antisamy:antisamy:jar:1.4.3:test
          \- commons-httpclient:commons-httpclient:jar:3.1:test
             \- (commons-logging:commons-logging:jar:1.0.4:test - omitted for conflict with 1.1.1)

1.1
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.owasp.esapi:esapi:jar:2.1.0:test
       \- commons-configuration:commons-configuration:jar:1.5:test
          +- (commons-logging:commons-logging:jar:1.1:test - omitted for conflict with 1.1.1)
          \- commons-digester:commons-digester:jar:1.8:test
             \- (commons-logging:commons-logging:jar:1.1:test - omitted for conflict with 1.1.1)

1.1.1
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.apache.ws.security:wss4j:jar:1.6.19:provided
       +- commons-logging:commons-logging:jar:1.1.1:provided
       \- org.apache.santuario:xmlsec:jar:1.5.8:provided
          \- (commons-logging:commons-logging:jar:1.1.1:provided - omitted for duplicate)

org.apache.santuario:xmlsec

[Error]
1.5.6
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.apache.ws.security:wss4j:jar:1.6.19:provided
       \- org.opensaml:opensaml:jar:2.6.1:provided (version managed from 2.5.1-1)
          \- org.opensaml:openws:jar:1.5.1:provided
             +- org.opensaml:xmltooling:jar:1.4.1:provided
             |  \- (org.apache.santuario:xmlsec:jar:1.5.6:provided - omitted for conflict with 1.5.8)
             \- (org.apache.santuario:xmlsec:jar:1.5.6:provided - omitted for conflict with 1.5.8)

  2. be.e_contract.dssp:dssp-client:jar:1.8.0
    \- org.apache.ws.security:wss4j:jar:1.6.19:test
       \- org.opensaml:opensaml:jar:2.6.1:test (version managed from 2.5.1-1)
          \- org.opensaml:openws:jar:1.5.1:test
             +- org.opensaml:xmltooling:jar:1.4.1:test
             |  \- (org.apache.santuario:xmlsec:jar:1.5.6:test - omitted for conflict with 1.5.8)
             \- (org.apache.santuario:xmlsec:jar:1.5.6:test - omitted for conflict with 1.5.8)

1.5.8
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.apache.ws.security:wss4j:jar:1.6.19:provided
       \- org.apache.santuario:xmlsec:jar:1.5.8:provided

  2. be.e_contract.dssp:dssp-client:jar:1.8.0
    \- org.apache.ws.security:wss4j:jar:1.6.19:test
       \- org.apache.santuario:xmlsec:jar:1.5.8:test

2.0.5
  1. be.e_contract.dssp:dssp-client-wss4j2:jar:1.8.0
    \- org.apache.wss4j:wss4j-ws-security-dom:jar:2.2.5:provided
       \- org.apache.wss4j:wss4j-ws-security-common:jar:2.2.5:provided
          \- org.opensaml:opensaml-saml-impl:jar:3.3.1:provided
             \- org.opensaml:opensaml-security-impl:jar:3.3.1:provided
                \- org.opensaml:opensaml-security-api:jar:3.3.1:provided
                   \- (org.apache.santuario:xmlsec:jar:2.0.5:provided - omitted for conflict with 2.1.5)

2.1.5
  1. be.e_contract.dssp:dssp-client-wss4j2:jar:1.8.0
    \- org.apache.wss4j:wss4j-ws-security-dom:jar:2.2.5:provided
       \- org.apache.wss4j:wss4j-ws-security-common:jar:2.2.5:provided
          \- org.apache.santuario:xmlsec:jar:2.1.5:provided

xerces:xercesImpl

[Error]
2.8.0
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.owasp.esapi:esapi:jar:2.1.0:test
       \- xom:xom:jar:1.2.5:test
          \- xerces:xercesImpl:jar:2.8.0:test

2.8.1
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.owasp.esapi:esapi:jar:2.1.0:test
       \- org.owasp.antisamy:antisamy:jar:1.4.3:test
          +- (xerces:xercesImpl:jar:2.8.1:test - omitted for conflict with 2.8.0)
          \- net.sourceforge.nekohtml:nekohtml:jar:1.9.12:test
             \- (xerces:xercesImpl:jar:2.8.1:test - omitted for conflict with 2.8.0)

xml-apis:xml-apis

[Error]
1.0.b2
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.owasp.esapi:esapi:jar:2.1.0:test
       \- xom:xom:jar:1.2.5:test
          \- xalan:xalan:jar:2.7.0:test
             \- (xml-apis:xml-apis:jar:1.0.b2:test - omitted for conflict with 1.3.03)

1.3.03
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.owasp.esapi:esapi:jar:2.1.0:test
       \- xom:xom:jar:1.2.5:test
          +- xml-apis:xml-apis:jar:1.3.03:test
          \- xerces:xercesImpl:jar:2.8.0:test
             \- (xml-apis:xml-apis:jar:1.3.03:test - omitted for duplicate)

1.3.04
  1. be.e_contract.dssp:dssp-client-wss4j1:jar:1.8.0
    \- org.owasp.esapi:esapi:jar:2.1.0:test
       \- org.owasp.antisamy:antisamy:jar:1.4.3:test
          \- org.apache.xmlgraphics:batik-css:jar:1.7:test
             +- org.apache.xmlgraphics:batik-ext:jar:1.7:test
             |  \- (xml-apis:xml-apis:jar:1.3.04:test - omitted for conflict with 1.3.03)
             \- (xml-apis:xml-apis:jar:1.3.04:test - omitted for conflict with 1.3.03)